From: Andrea Zagli <azagli@libero.it>
Date: Wed, 23 Oct 2019 09:01:47 +0000 (+0200)
Subject: Debian pkg: updates from upstream.
X-Git-Url: https://saetta.ns0.it/gitweb?a=commitdiff_plain;h=refs%2Fheads%2Fdebian%2Fwheezy;p=libgdaex

Debian pkg: updates from upstream.
---

diff --git a/debian/changelog b/debian/changelog
index a88f192..d33fb21 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,6 +1,6 @@
-libgdaex (0.6.0-1~4.gbpe808c6) UNRELEASED; urgency=medium
+libgdaex (0.6.0-1~5.gbpfde38a) UNRELEASED; urgency=medium
 
-  ** SNAPSHOT build @e808c62e9a87fa572fae05f500ca543545a39d72 **
+  ** SNAPSHOT build @fde38a03e518da41ada16d77a17e46b92b79e693 **
 
   [ Andrea Zagli ]
   * Initial release
@@ -24,4 +24,25 @@ libgdaex (0.6.0-1~4.gbpe808c6) UNRELEASED; urgency=medium
 
   [ tux ]
 
- -- tux <tux@develop64.example.tst>  Sat, 24 Jun 2017 08:52:57 +0200
+  [ Andrea Zagli ]
+  * Updates from upstream (enabled gir and gtk-doc).
+  * Setted version 0.7.0.
+  * Added functions GdaEx::metastore_update, ::metastore_get_tables and ::metastore_get_table_fields.
+  * Use of right functions to manipulate GdaMetacontext.
+  * Show field type and size in metastore test.
+  * Typo.
+  * Possible bug in libga gda_connection_get_meta_store_data_v.
+  * Added tool to export tables to csv.
+  * In ::save_data_file_in_blob value could be freed by GdaHolder.
+  * In ::save_data_file_in_blob removed g_value_unset.
+  * Wrong hashtable in get_sql_from_hashtable for GDAEX_SQL_DELETE.
+  * Fixed test getsqlfromhashtable for date and time.
+  * Added GdaEx::double_to_sql.
+  * Added function GdaExSqlBuilder::where_int.
+  * Added function GdaExSqlBuilder::where_string.
+  * Added function GdaExSqlBuilder::where_boolean.
+  * Added function GdaExSqlBuilder::where_float.
+  * Added functions GdaExSqlBuilder::field_*.
+  * Bugfix SqlBuilder: no table name if functions ::from* not called before others.
+
+ -- tux <tux@develop64.example.tst>  Wed, 23 Oct 2019 10:57:43 +0200
diff --git a/debian/patches/0005-old-gdametastore-functions.patch b/debian/patches/0005-old-gdametastore-functions.patch
new file mode 100644
index 0000000..9b06c5e
--- /dev/null
+++ b/debian/patches/0005-old-gdametastore-functions.patch
@@ -0,0 +1,62 @@
+diff --git a/src/gdaex.c b/src/gdaex.c
+index 3463659..695d2a3 100644
+--- a/src/gdaex.c
++++ b/src/gdaex.c
+@@ -3795,7 +3795,7 @@ GdaDataModel
+ 
+ 	GError *error;
+ 
+-	GdaMetaContext *mcontext;
++	GdaMetaContext mcontext = {"_tables", 0, NULL, NULL};
+ 
+ 	GdaExPrivate *priv = GDAEX_GET_PRIVATE (gdaex);
+ 
+@@ -3804,12 +3804,7 @@ GdaDataModel
+ 
+ 	if (update_meta_store)
+ 		{
+-			mcontext = gda_meta_context_new ();
+-
+-			gda_meta_context_set_table (mcontext, "_tables");
+-			gdaex_meta_store_update (gdaex, mcontext);
+-
+-			gda_meta_context_free (mcontext);
++			gdaex_meta_store_update (gdaex, &mcontext);
+ 		}
+ 
+ 	error = NULL;
+@@ -3836,7 +3831,7 @@ GdaDataModel
+ 	GError *error;
+ 	GValue *gval;
+ 
+-	GdaMetaContext *mcontext;
++	GdaMetaContext mcontext = {"_columns", 1, NULL, NULL};;
+ 
+ 	GdaExPrivate *priv = GDAEX_GET_PRIVATE (gdaex);
+ 
+@@ -3844,18 +3839,14 @@ GdaDataModel
+ 
+ 	if (update_meta_store)
+ 		{
+-			mcontext = gda_meta_context_new ();
+-
+-			gda_meta_context_set_table (mcontext, "_columns");
+-
+-			gval = gda_value_new (G_TYPE_STRING);
+-			g_value_set_string (gval, table_name);
+-			gda_meta_context_set_column (mcontext, "table_name", gval, priv->gda_conn);
+-
+-			gdaex_meta_store_update (gdaex, mcontext);
++			mcontext.column_names = g_new (gchar *, 1);
++			mcontext.column_names[0] = "table_name";
++			mcontext.column_values = g_new (GValue *, 1);
++			mcontext.column_values[0] = gda_value_new (G_TYPE_STRING);
++			g_value_take_string (mcontext.column_values[0],
++			                     gda_sql_identifier_quote (table_name, priv->gda_conn, NULL, FALSE, FALSE));
+ 
+-			gda_value_free (gval);
+-			gda_meta_context_free (mcontext);
++			gdaex_meta_store_update (gdaex, &mcontext);
+ 		}
+ 
+ 	/* possibile libgda bug: varchar length is always 0 */
diff --git a/debian/patches/0006-disable-tests.patch b/debian/patches/0006-disable-tests.patch
new file mode 100644
index 0000000..ec40f47
--- /dev/null
+++ b/debian/patches/0006-disable-tests.patch
@@ -0,0 +1,20 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -1,6 +1,6 @@
+ DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc --enable-introspection
+ 
+-SUBDIRS = data po src gdaex2gettext docs tests tools
++SUBDIRS = data po src gdaex2gettext docs tools
+ 
+ ACLOCAL_AMFLAGS = -I m4
+ 
+--- a/configure.ac
++++ b/configure.ac
+@@ -94,7 +94,6 @@ AC_CONFIG_FILES([
+ 	docs/reference/Makefile
+ 	docs/reference/version.xml
+ 	gdaex2gettext/Makefile
+-	tests/Makefile
+ 	tools/Makefile
+ 	po/Makefile.in
+ ])
diff --git a/debian/patches/series b/debian/patches/series
index bcc36f4..fb4236b 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -2,3 +2,5 @@
 0002-Glib-old-version.patch
 0003-Gda-old-version-constants-not-present.patch
 0004-Gtk-old-version-gtk_label_set_xalign.patch
+0005-old-gdametastore-functions.patch
+0006-disable-tests.patch
\ No newline at end of file