Ambiente PHP sotto win

  • l'ultima versione di php (5.5.x) richiede apache 2.4
  • installare apache
  • scompattare il php in un percorso senza spazi nel nome (es. c:\php)
  • aggiungere all'httpd.conf le righe
    LoadModule php5_module "C:/PHP_5.4.25/php5apache2_2.dll"
    AddType application/x-httpd-php .php
    PHPIniDir "C:/PHP_5.4.25"
  • abilitare le estensioni necessarie in php.ini
    • per mysql non è necessaria nessuna impostazione particolare
    • per postgresql aggiungere all'httpd.conf la riga (prima di LoadModule php5...)
      Loadfile "C:/PHP_5.4.25/Libpq.dll"